Mobile app performance
Incident Report for Pandle
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 27, 2019 - 16:01 GMT
Identified
We have identified an issue with loading historical invoices in the mobile app which may be affecting some users. We are actively working on a resolution. We apologise for the inconvenience this is causing and will issue further updates as we work on a resolution. All invoices remain accessible via the web app at my.pandle.co.uk.
Posted 12 months ago. May 02, 2018 - 12:54 BST
This incident affected: Mobile App (Android & iOS).